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Detail of Beverly Emmons’ layout for the Martha Graham Dance Company.



Introduction 

Virtual Magic Sheet displays lighting 

control levels in a format that follows the 

visual layout of your magic sheet, light 

plot, or any other organization you 

design. Channels do not need to be 

viewed in rigid rows and columns, but can 

be placed anywhere on the screen.

Objects

The basic visual display element is called 

an object. There are many types of 

objects. Channel objects show channel 

number and level, but they can also have 

names, colored backgrounds, and 

graphic visual representations of their 

levels.

Other display objects show color 

scrollers and additive or subtractive color 

mixing devices. Others show moving 

yoke or scanner mirror position. Still 

others can display control values such as 

non-dim states or gobo wheel positions.

VMS also offers a set of standard graphic 

elements for organizing and labeling the 

display, and a means to add background 

plans or drawings. The result is a magic 

sheet display designed to suit your own 

needs, filled with live data from the 

lighting console.

Live data

Virtual Magic Sheet can read certain 

lighting control networks directly to 

monitor level information. Through an 

optional DMX-USB adapter it can monitor 

any DMX control console. Multiple 

computers on a local network can run 

VMS concurrently, each displaying a 

different layout, but sharing the 

monitored control levels.

VMS uses patch information to associate 

each object with the correct data in the 

DMX stream. Objects can be patched 

using channels, fixtures, or absolute DMX 

addresses.
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Modes

VMS operates in two modes: “Offline” and 

“Live”. The Offline mode is used for 

designing and editing display layouts. 

The Live mode displays real-time DMX 

data in the layout. Use the Live and 

Offline commands in the Control menu to 

switch modes.

In Offline mode VMS can be used to 

create, edit and test layouts. To work in 

Live mode, VMS needs access to the DMX 

control data-stream. Currently VMS 

supports direct monitoring of DMX data 

through a USB adapter, and monitoring of 

Art-Net data through wired or wireless 

Ethernet. Devices are available to convert 

multiple universes of DMX to Art-Net for 

network distribution. 

This Guide

The Object Overview provides an 

introduction to all of the VMS object 

types. Object Properties looks at the 

mechanism for setting each object’s 

characteristics. The Channel Patch, 

Fixture Patch and Object Patch sections 

explain the details of how objects are 

connected to the control console data. 

Color Tricks describes means to make 

objects change color automatically. The 

Object Reference explains all of the 

display and patch properties for each 

object, and offers additional notes about 

their usage. The Layouts section explains 

the working space where all of those 

objects are displayed. At the end of the 

guide you’ll find Tips and Tricks, 

Magnified View, Multiple Universes, 

Menu Shortcut Keys, Installation, VMS 

Editions, Registration & Authorization, 

Help & Support, and Credits.

All features of the Mac and Windows 

versions of VMS, which are nearly 

identical, are addressed. Many pop-up 

contextual menu commands are 

available, which are accessed by right-

clicking in Windows, or by ctrl-clicking 

on a Mac. This guide will designate these 

as right/ctrl-clicks.

Built-in Help

VMS contains an extensive built-in help 

system which reflects much of the 

material in this guide. Use the Help > 

VMS Help command to access it.
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Object Overview 

There are eight types of live objects 

which respond to DMX level data: 

Channel

Scroller

RGB

CMY

Yoke

Scanner

Command

DMX Level

There are also six graphic objects: 

Line

Arrow

Rectangle

Oval

Text

Picture

In the next few pages we’ll take a quick 

look at the features of each type of 

object. The Object Reference section 

contains more details about how to 

operate those features.
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Channel object 

The Channel object shows the channel 

number and percentage level, as you 

would expect. It also has several 

additional display options. 

Channel objects can show a short label 

and the filter number above the channel. 

The background color of the object 

approximates the filter color. 

The channel object can have up/down 

arrows showing the direction of the most 

recent change in level. 

The channel level can be displayed as a 

percentage, or as full-range DMX in 

decimal (000-255) or hexadecimal (x00-

xFF), and the level can be displayed in 

larger text. 

A bar graph, circular gauge, or fading 

color field can also be enabled, showing 

at a glance the relative levels of a group 

of channels. 

 

bar

 

circle

 

fade

Scroller object 

The scroller object displays the current 

color selection of a color scroller or a 

moving light’s color wheel, as well as the 

current frame number, and the color filter 

number. 
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The scroller object has a “frame list” 

property containing the list of colors. A 

color is automatically selected from the 

list based on the control channel level. 

Levels can be assigned to each color to 

fine-tune the tracking of physical scroller 

positions.

Yoke and Scanner objects 

The Yoke and Scanner objects graphically 

display the pan and tilt values of a moving 

light fixture, and can maintain a list of 

named preset focus points. 

The Yoke object, on the left, shows the pan 

(arc) and tilt (line through the center) and 

the resulting focus direction (dot), all in a 

circular diagram. The vertical white line is 

the zero pan position, and the red mark 

shows the pan limit, in this case 400 

degrees. 

The Scanner object, on the right in the 

picture, shows the result of pan and tilt in 

a square diagram. The diagonal line 

marks the corner where pan and tilt are 

both zero. 

Both types of objects can be rotated to 

match the actual hanging orientation. 

Additionally, pan and/or tilt axis data can 

be inverted, and the two axes can be 

swapped.

Each object can have an ID, which can be 

any name or number and is not related to 

the channel patch. The words below the 

objects are names of the pan/tilt positions 

matching the current dmx data. To record 

a position (in live mode) simply right/ctrl-

click on the object, select Record Point, 

and type a name. Whenever the pan and 

tilt match the recorded position, the 

position name will be displayed.

DMX Level object 

The DMX Level object simply displays a 

control level. It can show either a single 8-

bit DMX level, or a 16-bit level from two 

DMX slots. It can display the level as a 

percentage (0-FL) or full-range (000-255 

or 00000-65535) or hexadecimal (x00-xFF 
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or x0000-xFFFF). It can have a color and 

an ID label.

RGB object 

The RGB object displays a mix of red, 

green, and blue primary colors, which 

might be produced by an LED fixture, for 

example. Red, green, and blue bars show 

the levels of each color component, and a 

larger color swatch shows the resulting 

mix.

CMY object 

The CMY object displays a mix of cyan, 

magenta, and yellow secondary colors, 

which might be produced by a moving 

light fixture, for example. Cyan, magenta, 

and yellow bars show the levels of each 

color component, and a larger swatch 

shows the resulting mix. 

Command object 

The command object is used to display a 

text label reflecting the state of a 

command channel. The text displayed is 

automatically selected based on the 

channel’s level. 

The command object can 

also optionally show a 

text label, the control 

channel number, and the raw DMX level 

(000-255).

Line object 

The Line object can be used to separate, 

structure, and organize sections of the 

layout. It can be drawn at any angle, and 

can have any color and line width. When 

selected, the line can be manipulated by 

dragging the square handles at each 

endpoint. 
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Arrow object 

The arrow object can be used to show 

lighting direction or to highlight 

important items on a layout. The arrow’s 

color and line width can be changed. 

Rectangle object 

The rectangle object can be used to add 

visual organization and structure to the 

layout. When selected, it can be resized 

using the square handles at its corners.

Oval object 

The oval object can be used as another 

visual aid on the layout. When selected, 

an oval can be resized using the square 

handles at the corners of the selection 

rectangle.

Text object 

The Text object is used to add text labels 

to the layout. The color, size, and style 

(bold, italic, underline) of the text can 

easily be changed.
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Picture object 

The picture object can provide an overall 

background or add a graphic detail to a 

layout. 

An image with a white background can 

be shown in negative, as seen in the 

example above, and the overall 

brightness of a picture can be adjusted 

for best integration into the VMS layout 

design. 

8



Object Properties 

Properties of objects, for example 

channel and filter number of a channel 

object, or line weight and color of a 

graphic object, can be changed in the 

Object Editor. The Object Editor is 

opened by the Edit > Show Editor 

command, or by right/ctrl-clicking an 

object and selecting Edit from the 

contextual menu.

 

The Object Editor lists all properties for 

the currently selected objects. Clicking 

on a property in the Object Editor allows 

editing of that property for all selected 

objects. 

Right/ctrl-clicking an object displays a 

menu of object-related commands. 

Edit will open the Object Editor. Lock will 

prevent an object from being selected or 

moved. The Unlock command unlocks it.  

To quickly assign a series of channel 

numbers to a series of objects, select the 

lowest numbered channel object and set 

its channel number, then right/ctrl-click 

the object and choose the Get Channel 

command. This will use the object’s 

channel number as the base for the 

series. 

Right/ctrl-click the object needing the 

next highest channel number and choose 

Next Chan to assign it. Repeat the Next 

Chan command on each object in the 

sequence. The channel number that will 

be assigned is shown in parentheses.
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VMS uses the channel patch to associate 

DMX slots (addresses) with channel 

numbers so that it can send the correct 

DMX level data to objects patched as 

channels. 

The Patch > Show Channel Patch 

command opens the patch window where 

the channel patch information can be 

entered. 

Each row in the window represents one 

DMX slot. Use the pop-up menu to choose 

Dimmer or Univ/Addr display.

Channel numbers or other identifying 

designators can be entered for each DMX 

slot, as shown in the screen-shot. Channel 

designations on this list are matched to 

objects and the DMX level from the 

associated slot is sent to the object.

The entire patch list can be sorted by 

clicking on any column heading. To sort 

by channel, click on Chan. To sort by 

dimmer or universe/address, click on the 

blank heading below the pop-up menu. 

Clicking a second time will reverse the 

sort order.

The Patch > Clear Channel Patch menu 

command clears all channel assignments. 

The Patch > Set Patch 1:1 command sets 

all channel numbers equal to dimmer 

numbers.

Channel Patch 
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Pressing the More button reveals two 

additional  columns showing current live 

DMX level (0-255) and optional 

proportional percentage (1-100).

The proportional percentage is used to 

undo any proportional level reduction set 

on a dimmer and display the proper 

channel intensity based on the reduced 

DMX level. Proportional intensity entered 

here should match the proportional 

intensity set for the dimmer at the control 

console.

Patch information can be imported 

directly from a Lightwright 4 file. Use the 

Patch > Load Lightwright 4 Patch… 

command. A USITT ASCII text format 

patch, exported from Lightwright, 

Expression Offline or Showport, for 

example, can be loaded by using the 

Patch > Load ASCII Patch… command.

VMS Objects which are patched as 

fixtures or dmx devices do not use the 

channel information from this patch. The 

objects’ levels do, however, reflect any 

proportional percentage assigned in the 

Channel Patch window.

There is no provision at this time for non-

sequential dimmer numbering. The first 

slot in universe 2 is always dimmer 513, 

the first slot in universe 3 is always 1025, 

etc. There is no direct support for ETC 

Dimmer Doubling, however the arithmetic 

is simple: add 256 to the “A” dimmer 

number to find its “B” dimmer address. 

For example, dimmer 1B is 1 + 256 = DMX 

address 257.
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Fixture Patch 

VMS uses the fixture patch to associate 

DMX addresses with fixture designations 

so that it can send the correct DMX level 

data to objects patched as fixtures. The 

Patch > Show Fixture Patch command 

opens the fixture patch window where the 

fixture patch information can be entered. 

Click New to create a new fixture line. 

Enter the Fixture number, or other 

designation, that you will use when 

associating an object with this fixture. 

Enter the DMX universe and start address 

of the fixture. Click New again to create 

another fixture. Click Apply to 

immediately apply a change to the 

layout, or OK to close the window and 

apply any changes.
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Fixture patching example

Fixture 5 is a moving light having 10 dmx 

slots for its attributes. The fixture is 

plugged into DMX universe 1, and 

addressed at 405. 

In the Fixture Patch window:

 Create a New fixture.

 Set its fixture designation to 5.

 Set its universe to 1.

 Set its address to 405. 

Now we can create objects to display 

attributes of this fixture and patch them to 

“fixture 5”. If the fixture’s patch is ever 

changed, all objects will automatically be 

updated with the new universe and 

address information. 
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Object patch 
Live objects display DMX level 

information. An object can be patched to 

the desired data in one of three ways. 

1 - As a channel, in which case it receives 

its data from a source listed in the 

Channel Patch window. 

2 - As a fixture component, in which case 

it uses the base address listed for the 

fixture in the Fixture Patch window, 

combined with the dmx seq value which 

specifies which dmx data slot(s) within 

the fixture the object is to monitor. 

3 - As a generic DMX Device component, 

in which case the DMX universe, start 

address, and dmx seq value are specified 

as properties of the object.

The following data patching properties 

are available for scroller, yoke, scanner, 

command, DMX level, RGB and CMY 

objects. 

Channel objects can be patched only as 

channels.

Object patch property summary

ID identifying label, could be channel or fixture designation

patched as choice of: channel, fixture, or dmx device

when patched as a channel:

channel control channel, can be number or any text, from channel patch

when patched as a fixture:

fixture fixture, can be number or any text, from fixture patch

dmx seq dmx slot within fixture (1-512)

when patched as a DMX device:

universe universe number of dmx device (1-8 in current version of VMS)

start addr start address of dmx device (1-512)

dmx seq dmx slot within dmx device (1-512)
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Yoke patching example

Create a Yoke object. In the Object Editor: 

 Select patched as and set to fixture. 

 Select fixture and set to 5. 

 Select dmx seq pan and set to 2, which is the dmx sequence number within 

the fixture of the pan attribute. 

 Select dmx seq tilt and set to 3.
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CMY patching example

Create a CMY object. In the Object Editor:

 Select patched as and set to fixture. 

 Select fixture and set to 5. 

 Select dmx seq cyan and set to 5, which is the dmx sequence number within 

the fixture of the cyan attribute. 

 Select dmx seq mag and set to 6. 

 Select dmx seq yellow and set to 7.
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Color Tricks 

Color Linking

Scroller, RGB and CMY objects can be 

assigned as color sources for other 

objects by establishing a color link 

between a source and receiver object. 

When the source object’s color changes 

due to a control level change the receiver 

objects will also take on the new color. 

For example, a scroller might be linked to 

a channel so that the channel object is 

drawn in the currently selected scroller 

color. A CMY object might be linked to a 

yoke so that the yoke’s focus dot is drawn 

using the current CMY color mix.

A link is created by first selecting the 

color source object (scroller, RGB, CMY) 

and choosing Edit > Copy Color. Next, 

select one or more receiver objects and 

choose Edit > Paste Color/Link. The 

receivers will now always be drawn in the 

source object’s color.

To break a link, select the receiver object 

and assign it a specific color, or in the 

case of a channel, assign it a filter or 

“NC”.

Any of the following objects can be color 

receivers: Channel, Yoke, Scanner, 

Command, Line, Arrow, Rect, Oval, Text, 

DMX Level. Any of them can be linked to 

a Scroller, RGB or CMY color source.

The color property of a selected channel 

can be copied by using the Edit > 

Copy Color command, and then be 

pasted onto any other selection of 

channels by using the Edit > Paste Color 

command.

Manual Color Changes

If a fixture’s color is changed manually 

during a  performance, VMS provides a 

means to assign multiple colors to a 

fixture, identify each one with a “color 

setup” and easily switch between setups 

when colors are changed..

A list of all of the filters used in a channel 

may be entered in the color property and 

each filter can be associated with a color 

setup name, which might be the name of 

the act or the dance piece when the color 

is used.
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For example, if a dance sidelight channel 

is normally no color, but is manually 

changed to R25 for “Rondo” and R80 for 

“Windsail”, the channel object’s color 

property would look like this:

NC, R25 @ Rondo, R80 @ Windsail

Use the Display > Color Setups menu to 

select a setup. All channels having a filter 

assigned to that setup will change to the 

filter assigned for that setup. any channel 

not having a filter assigned to the 

selected setup will be unaffected. 

Selecting the color setup “Windsail” will 

change the example channel to R80. 

Selecting “default” will change it to no 

color.

For automated color changes, use the 

scroller object.
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Object Reference 

The following pages contain a detailed 

look at all of the properties for each 

object type.
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Channel object 

Properties:

channel channel number (which does not need to be an actual “number”)

filter color filter identifier, or list of color changes

gauge enable analog gauge display

gauge side B, T, L or R to signify from which side of the object the bar gauge grows

level big use larger type size for level

level dmx display level as DMX 000-255

level hex display DMX level as hexadecimal x00-xFF

locked enable selection lockout

label text label for channel

show filter enable color number display

show up/dn enable up/down direction display

underline underline the channel number

Notes:

The color of the up/down indicators can be set in the preferences window to match 

control console display coloring.

A channel object can be a color receiver. For example, its color can be controlled by a 

scroller object. In this case the filter property is ignored.
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DMX Level object 

Properties:

dmx 16-bit enable 16-bit level display

dmx seq coarse DMX sequence number relative to the channel, fixture or device start 

address, of the high-order half of the level value

dmx seq fine DMX sequence number of the low-order half of the level value

color drawing color *

gauge enable analog gauge display

gauge side B, T, L or R to signify from which side of object the bar gauge grows

level big use larger type size for level

level dmx display level as DMX 000-255 (or 00000-65535 if 16-bit)

level hex display DMX level as hexadecimal x00-xFF (or x0000-xFFFF if 16-bit)

locked enable selection lockout

show up/dn enable up/down direction display

Notes:

* A DMX Level object can be a color receiver.

A DMX Level object can be patched as a channel, fixture, or dmx device.
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Scroller object 

Properties:

frame 0 label the first frame number as 0, instead of 1

frame list list of colors, separated by commas, for example: 

 NC, R01, L105, G315, L132, R80 …

 Or with levels:

 NC@0, R01@3, L105@7, G315@11, L132@14, R80@18 …

locked enable selection lockout

show ID enable display of ID in center of scroller

Notes:

A scroller can be a color source for other objects.

A scroller can be patched as a channel, fixture, or dmx device.
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RGB object 

Properties:

dmx seq red dmx address of the red component, where 1 signifies that red is at the 

start DMX address of the specified channel, fixture, or device

dmx seq green dmx address of the green component

dmx seq blue dmx address of the blue component

locked enable selection lockout

Notes:

An RGB object can be a color source for other objects.

An RGB object can be patched as a channel, fixture, or dmx device.

CMY object 

Properties:

dmx seq cyan dmx address of the cyan component, where 1 signifies that cyan is at the 

start DMX address of the specified channel, fixture, or device

dmx seq mag dmx address of the magenta component

dmx seq yellow dmx address of the yellow component

locked enable selection lockout

Notes:

A CMY object can be a color source for other objects.

A CMY object can be patched as a channel, fixture, or dmx device.
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Yoke and Scanner objects 

Properties:

dmx seq pan dmx address of pan attribute within device, where 1 signifies that pan is 

at the start DMX address of the specified channel, fixture, or device

dmx seq tilt dmx address of tilt attribute within device

dot color color of focus indicator dot *

double size causes object to be drawn at twice the normal size

invert pan causes pan data to be inverted, useful when fixture has this option 

enabled

invert tilt causes tilt data to be inverted

locked enable selection lockout

max pan (Yoke object only) maximum pan travel in degrees

orientation angular orientation in degrees clockwise from normal

swap pan/tilt exchange the pan and tilt data

Notes:

* A Yoke or Scanner can be a color receiver.

A Yoke or Scanner can be patched as a channel, fixture, or dmx device.
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Command object 

Properties:

states state/level list as described below

color text color for all data *

locked enable selection lockout

show chan enables control channel number display

show level enables DMX level display

size text size, in points, for all data

style bold enables bold style

style italic enables italic style

underline enables underline style

Notes:

A command object might be used for a simple non-dim channel, displaying ON or OFF. 

It might be used for an automated fixture’s reset channel, displaying NORMAL or RESET. 

For a gobo selector channel it might show OPEN, DOTS, RAYS, LINE, CIRCLE, SPIN.

The states property is a list of commands and their associated control levels. A non-dim 

channel might have a list like this: 

OFF@0, ON@50

The reset channel for a fixture which resets only at DMX level 250 would look like this: 

NORMAL@0, RESET@250d, NORMAL@251d 

where the “d” designates a DMX, rather than percentage, control level. 
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Note that only the lowest level in each state is listed. In the reset example, NORMAL 

would be displayed for every DMX level from 0 through 249. At DMX 250 the display 

would show RESET. At DMX 251 and higher it would again show NORMAL.

* A Command object can be a color receiver.

A Command object can be patched as a channel, fixture, or dmx device.

26



Line object 

Properties:

line color drawing color for line *

line width pen width, in pixels, for line

locked enable selection lockout

Notes:

* A Line can be a color receiver.

Arrow object 

Properties:

direction orientation, as noted below

line color drawing color for arrow *

line width pen width, in pixels, of arrow

locked enable selection lockout

Notes:

An arrow’s orientation can be specified by compass direction (N, S, E, W, NE, SE, SW, 

NW) or by clock direction (1 – 12) or by degrees clockwise from up (example: 25d). 

* An Arrow can be a color receiver.
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Rectangle object 

Properties:

filled enables solid rectangle

line color drawing color for rectangle *

line width pen width, in pixels, of rectangle outline

locked enable selection lockout

Notes:

* A Rectangle can be a color receiver.

Oval object 

Properties:

filled enables solid oval

line color drawing color for oval *

line width pen width, in pixels, of oval outline

locked enable selection lockout

Notes:

* An Oval can be a color receiver.
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Text object 

Properties:

text the text label to be displayed

color the drawing color for the label *

locked enable selection lockout

size point size of the label

style bold enables bold text style

style italic enables italic text style

underline enables underline text style

Notes:

* A Text object can be a color receiver.
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Picture object 

Properties:

brightness overall brightness 0-100 for image display

locked enable selection lockout

negative show picture as negative

print neg. enable print picture as negative

Notes:

Create a picture object by copying a picture and pasting it onto the layout. (On a Mac 

you may also drag and drop a picture or picture file.) The picture object can then be 

moved and resized as needed.

A scanned stage plan, light plot or channel list can provide a background for other 

objects. When a picture object is used as a background it is best to move it to the back 

and lock it so that it will not be selected when trying to drag-select multiple objects that 

are in front of it. 
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Kendall Smith’s layout for “The Daughter of the Regiment” at Michigan Opera.
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Layouts 

The VMS window has a scrolling layout 

area with a tool bar above it. New objects 

are created by dragging an object name 

from the tool bar into the layout area. 

Objects can also be created by right/ctrl-

clicking in a blank area of the layout. A 

pop-up menu allows you to choose the 

type of object to add at that location. An 

invisible grid keeps objects in neat 

alignment. (This grid snap feature can be 

turned off from the Align menu.)

Selecting Objects

An object can be selected by clicking on 

it. A yellow border indicates a selected 

object. Shift-click to select additional 

objects, or to deselect an object. 

Click down on the background and drag 

to create a rectangle which will select all 

of the objects it encloses. Again, shift will 

select the enclosed objects, or will 

deselect enclosed objects which are 

already selected, without changing the 

selection state of other objects. Hold the 

alt/option key while dragging to include 

any objects touched by the rectangle.

Moving and Aligning Objects

Drag a selected object, or use the arrow 

keys, to move all currently selected 

objects.

A group of objects can be aligned to each 

other by commands in the Arrange 

menu. You can align the objects’ tops, 

bottoms, right sides, left sides, horizontal 

centers, or vertical centers. The Flip Left/

Right and Flip Up/Down commands flip 

the selected object grouping.

Resizing and Stacking Objects

Some graphic objects are resizable. When 

selected, a resizable object has square 

“handles” at the corners, which may be 

dragged to change the object’s size. 

Holding the shift key while resizing 

preserves the object’s original shape.

Objects have an inherent stacking order. 

New objects appear in front of older 
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objects when they overlap. The front-to-

back stacking order of objects can be 

changed by selecting an object and using 

the Move To Front and Move To Back 

commands in the Arrange menu.

Locking Objects and Layouts

Objects can be locked. A locked object 

cannot be accidentally selected or 

moved. To unlock an object right/ctrl-

click on the object and select Unlock.

The entire layout can also be locked to 

prevent any changes. Use the Edit > Lock 

Layout menu command.

Rows of Channels

Multiple channels can be created at once 

by dragging the Rows tool to the layout, 

or by right/ctrl-clicking on the layout 

background and selecting New Rows. In 

the entry box that appears enter the first 

channel number, then “-” for “through”, 

then the last channel number. For 

example 1-10 creates channels 1 through 

10. For multiple rows add an “x” and 

number of channels per row. Enter 

1-80x20 (“1 through 80 by 20”) to make 

80 channels in rows of 20. The upper left 

channel will be placed at the mouse click 

or drop location on the layout.

If the “first” channel number is higher 

than the “last” channel number, the 

objects will be numbered in descending 

order from left to right. If no row size is 

entered, all channels will be in one row. 

To make a column, specify a row size of 1. 

Under the New Objects tab in the 

Preferences window you can specify that 

space be added between channels and 

between rows. 
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Layout Files 

The File menu 

provides 

commands for 

opening and 

saving layouts. 

When saving a 

layout, VMS 

creates a 

folder containing both the VMS file and a 

folder of miscellaneous support files. 

When opening a saved file, open the VMS 

file inside the enclosing folder.

File > Open… opens a previously saved 

layout. The current objects and patch are 

replaced by the contents of the layout file.

File > Add Objects From… opens a 

previously saved layout and adds its 

objects to the current layout.

File > Save re-saves the current layout file 

with any changes.

File > Save As… saves the current layout 

with a new name. Future saves will go to 

this new file.

File > Save a Copy saves a copy of the 

current layout with a new name. Future 

saves will go to the original file, not this 

new copy.

File > Fit To Page enables automatic 

sizing so that the layout will fit on one 

printed page.

File > Page Setup… opens the standard 

printer setup dialog.

File > Print… prints a modified version of 

the layout. In the printed version the 

black background is replaced with white, 

and the solid channel colors are replaced 

with colored outlines. These changes save 

printer ink and produce a page with free 

space to write notes. Any white text or 

objects are printed as black on the white 

background. The printed layout shows no 

level information.
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VMS Tips and Tricks 

Useful when Offline:

Arrow keys move the selected object(s).

The delete or backspace key will delete 

the selected objects.

The Edit > Lock Layout command locks 

and unlocks the entire layout. When the 

layout is locked, no objects can be 

selected, whether or not they are 

individually locked.

Hold shift while resizing an object to 

preserve its original shape.

If parts of your layout mirror left and 

right, make the objects for one side, 

select them, Edit > Copy, Edit > Paste, 

Arrange > Flip Left/Right, and then drag 

the flipped objects to the proper 

location. You can also mirror up and down 

with Arrange > Flip Up/Down.

The Preferences command opens a 

window where you may set general VMS 

preferences. Under the Chans tab are 

color selectors for the up/down indicator 

colors, a checkbox for italicized channel 

numbers, and a level gauge style 

selection. Under the New Objects tab you 

may choose whether new channel objects 

will initially have the gauge display 

enabled, whether you will be queried for 

basic information (for example ID or 

channel number) when creating a new 

object, and whether new rows of channels 

will have space between objects.

VMS recognizes several designations for 

white: R00, NC, N/C, OW, O/W and CLR. 

Capitalization is not required.

To preview your layout in Offline mode, 

use the Control > Faders menu command 

to open a small fader control which sends 

levels to the first ten dmx slots of each 

universe, or to all slots. You can also use 

the Control > Demo Levels command to 

send random level to all slots. Control > 

To Zero will clear the test levels.
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Useful when Live:

The Display > Full Screen command 

hides the menu bar and places VMS in 

full-screen mode. Use the menu shortcut 

ctrl/cmd-shift-F, or move the cursor to the 

top of the screen, to restore the menu bar.

Display > Clock enables display of the 

current time in the upper right corner 

(Mac) or lower right corner (Windows) of 

the VMS window. This display is useful in 

Full Screen mode when the system clock 

is hidden.

The Display > Black command blacks out 

the display – handy during very dark 

moments in a rehearsal when a screen 

display would be distracting. A message 

reminds you to press any letter key to 

restore the VMS display.

Display > Clear Up/Down clears all 

channel direction arrows. A new arrow 

will appear on a channel when the 

channel’s level next changes. Arrows are 

automatically cleared at the first level 

change following 5 or more seconds of 

inactivity.

Useful Offline or Live:

Hold the alt/option key and press any 

arrow key to scroll the layout.

Use the Edit > Find command to highlight 

objects having a specific channel or 

label.
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Magnified View 

The Windows > Magnify command opens 

a 2x magnification window which can be 

resized and positioned anywhere on the 

screen. Click anywhere on the layout to 

choose the center point of the magnified 

area.

Note that this screenshot shows the 

following objects: channels, scrollers, 

yokes, text objects, an arrow, a rectangle, 

an oval, and a picture as a background.
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Multiple DMX-USB adapters may be used 

to monitor multiple DMX universes. Use 

the Control > Show USB Adapters 

command to see which adapter is 

assigned to each universe. At this time 

there is not a means to change the 

automatic universe assignments.

When using Art-Net, VMS monitors subnet 

0, universes 1 through 8. 

Multiple Universes 

38



Dan Rousseau’s layout for “Joseph and the Amazing Technicolor Dreamcoat”. 
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Menu Shortcut Keys 
Use with ctrl key (Windows) or cmd/apple/fan key (Mac)

,(comma) Apple > Preferences (Mac) or 

 Display > Preferences (Windows)

O File > Open

shift-O File > Add Objects From

S File > Save

shift-S File > Save As

P File > Print

Z Edit > Undo/Redo

F Edit > Find

X Edit > Cut

C Edit > Copy

shift-C Edit > Copy Color

V Edit > Paste

shift-V Edit > Paste Color (/Link)

E Edit > Show Object Editor

A Edit > Select All Not Locked

alt/opt-A Edit > Select All

alt/opt-T Arrange > Align Tops

alt/opt-B Arrange > Align Bottoms

alt/opt-L Arrange > Align Lefts

alt/opt-R Arrange > Align Rights

> Arrange > Move To Front

< Arrange > Move To Back
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shift-F Display > Full Screen

B Display > Black

U Display > Clear Up/Down

W Window > Close

M Window > Magnify

L Control > Test Levels

0(zero) Control > To Zero

? Help > VMS Help
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Computer Requirements 

Windows XP with Service Pack 2 / Macintosh OS X (10.2 or later)

800x600 minimum display resolution

Optional USB-DMX adapter requires powered USB port or hub

Optional network operation requires Ethernet network interface connection (wired or 

wireless)

Windows XP Installation 

The VMS distribution CD contains a PDF 

version of this User’s Guide, and folders 

for the Mac OS X and Windows XP 

installations. Inside each of these folders 

is a VMS folder, and USB driver 

information. Drag the VMS Win folder to 

your desktop, or wherever you like. It 

contains the application itself and the 

Help file, which must always be in the 

same folder as the application. See the 

directions below for DMX-USB driver 

installation if you are using that option.

Driver Installation

You may use the driver provided on the 

VMS CD, or to ensure that you have the 

latest driver, visit www.ftdichip.com . On 

that web page click on the Drivers link. 

You'll then need to choose the FT245BM 

driver, VCP type, and Windows XP. 

Download the driver, extract the files from 

the zip archive, and follow the FTDI 

installation instructions, summarized 

below. You will need to restart your 

computer after the installation. These 

instructions are included in the Help 

function within VMS.

1. Plug the DMX-USB adapter into 

your computer. The Found New 

Hardware Wizard will open. If it 

does not, follow the Driver 

Removal instructions below.

2. Select No, not at this time and 

click Next.

3. Select Install from a list or 

specific location and click Next.
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4. Select "Search for the best 

driver...".

5. Check "Include this location in 

search".

6. Click Browse.

7. Navigate to the folder that you 

downloaded above, or to the 

driver folder on the CD.

8. Click OK.

9. Click Next. One driver file will be 

installed.

10. Click Finish. The Found New 

Hardware Wizard will open again.

11. Select No, not at this time and 

click Next.

12. Select Install from a list or 

specific location and click Next.

13. Click Next. Second driver file will 

be installed.

14. Tool tray message will pop up 

saying that new hardware was 

installed. Restart your computer.

Driver Removal

1. Unplug the DMX-USB Adapter 

from the computer

2. Select Control Panel from the 

Start menu.

3. Select Add or Remove Programs 

(single or double-click to open, 

depending on your control panel 

mode.)

4. Select FTDI USB Serial Converter 

and click Change/Remove

5. In new window click Continue.

6. Click Finish.

7. Close the Add or Remove 

Program" window.

Now proceed with Driver Installation 

instructions step 1.
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Mac OS X Installation 

The VMS distribution CD contains a PDF 

version of this User’s Guide, and folders 

for the Mac OS X and Windows XP 

installations. Inside each of these folders 

is a VMS folder, and USB driver 

information. Drag the VMS Mac folder to 

your desktop, Applications folder, or 

wherever you like. It contains the 

application itself and the Help file, which 

must always be in the same folder as the 

application. If you are using the DMX-USB 

adapter, see the directions below for 

driver installation.

Driver Installation

You may use the driver installer on the 

VMS CD starting with step 2 below, or to 

ensure that you have the latest driver, visit 

www.ftdichip.com . On that web page 

click on the Drivers link. You'll then need 

to choose the FT245BM driver, VCP type, 

and your specific operating system, Mac 

OS X. Download the driver and follow the 

FTDI installation instructions, summarized 

below. You will need to restart your 

computer after the installation. The 

instructions below are also included in 

the Help function within VMS

1. Double-click the downloaded 

package to unstuff the installer.

2. Double-click the installer.

3. Follow the installation prompts. You 

will be asked to provide an 

Administrator account password 

during the installation.

4. When the installation is complete, 

click the Restart button on the 

installer window to restart your 

computer.
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VMS Editions 
VMS is available in four editions which 

differ in the number of live objects 

supported. The free VMS-demo edition 

supports 10 live objects. Purchased 

editions support 250, 500 or 1,000 live 

objects. 

Any edition, including the demo, can edit 

any size layout in offline mode; the 

restriction only affects the number of 

objects which will respond to control 

information in live mode. 

The number of live objects authorized for 

an edition of VMS and the number of 

unused objects remaining are displayed 

at the bottom of the “About” window. Use 

the About Virtual Magic Sheet... 

command.

When a layout uses more live objects than 

are supported, some objects will appear 

as below in live mode.

Networking 
Multiple copies of VMS running on the 

same local network can share one 

authorization. As long as the authorized 

copy is running, other copies including 

free VMS-demo copies will temporarily 

support the number of objects authorized 

for the “host” copy of VMS.

DMX data monitored by a USB adapter 

can also be shared. An authorized copy of 

VMS will broadcast data from one or two 

USB-DMX adapters onto the local network 

for other copies of VMS to use. 

Network control data, for example Art-Net 

data, is by its nature available to all 

copies of VMS running on the local 

network.
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Each copy of VMS is initially locked in 

demo mode. To unlock it you will need to 

purchase a serial number, which is 

combined with a registered user name 

and unique authorization code to enable 

the number of live objects supported by 

the edition purchased.

You may easily request an authorization 

code by e-mail if you have an e-mail 

application installed on the VMS 

computer.

1. Start VMS and select the Help > 

Request Authorization Code 

command.

2. In the registration window enter your 

desired registration name, the 

requested contact information for 

support, and your VMS serial number.

3. Click the e-mail button to activate 

your e-mail application and cause the 

information to be written into a 

message.

4. Send the e-mail.

If you do not have an e-mail application 

installed on the VMS computer, send an e-

mail containing all of the requested 

information to: 

sales@goddarddesign.com .

When you receive your authorization 

code by reply e-mail, choose the VMS 

Help > Enter Authorization Code 

command. The serial number and 

registration name should already be filled 

in. Copy the registration code from the 

reply e-mail, paste it into the registration 

window, and click the Authorize button.

If you do not receive your e-mail on the 

VMS computer you will need to type the 

serial number, registration name, and 

authorization code into the window.

Registration & Authoriztion 
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Help & Support 

Help is always only a click away within 

VMS. The Help > VMS Help menu 

command opens the built-in help system. 

It contains much of the information in this 

guide. It is searchable and you can copy 

or print individual pages.

If you have questions about purchasing or 

installing Virtual Magic Sheet, contact the 

distributor, Goddard Design Company:

for sales questions:

sales@goddarddesign.com

for support questions:

goddard@goddarddesign.net

or phone +1-718-599-0170

 

If you have esoteric questions or ideas 

about the use or design of VMS itself, 

write to the developer, Eric Cornwell, at 

West Side Systems: 

eric@westsidesystems.com
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Richard Pilbrow and Dawn Chiang’s layout for “The Boyfriend” at Goodspeed Musicals.
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